PDA

View Full Version : genext2fs: couldn't allocate a block (no free space)



LeFred
June 30th, 2010, 08:01 AM
Hi all,

I had a working mmu linux, but after adding few more modules, the make fails.
What could be the solution ? (my hard disk isn't full :))

Thanks.


make image.rootfs.all
make[3]: Entering directory `/home/linux_nios/nios2-linux/uClinux-dist/vendors/hvse/nmu400'
/home/linux_nios/nios2-linux/uClinux-dist/user/genext2fs/build-host/genext2fs -m 0 -i 1024 -b 8192 -d /home/linux_nios/nios2-linux/uClinux-dist/romfs -D device_table.txt /home/linux_nios/nios2-linux/uClinux-dist/images/rootfs.ext2
/home/linux_nios/nios2-linux/uClinux-dist/user/genext2fs/build-host/genext2fs: couldn't allocate a block (no free space)
make[3]: *** [image.rootfs.ext2.force] Error 1
make[3]: Leaving directory `/home/linux_nios/nios2-linux/uClinux-dist/vendors/hvse/nmu400'

slacker
June 30th, 2010, 08:28 AM
Try increasing the size of the romfs image (-b 8192 to -b 16384). The message indicates that you've run out of space.

--slacker

LeFred
July 1st, 2010, 02:29 AM
Thank you Slacker.

It sounds good to increase the size of this, but I've looked for the definition place of this parameter:
I found that it is defined in uClinux-dist/user/Kconfig:

config USER_RAMIMAGE_RAMFS8192
bool "8192K"

There is other choices from 64k up to 8192k, but no more !
So is it really possible to increase that ?

Anyway I find an alternative solution in removing "cxx c++ test apps" from the build (saves about 1 500k !)