Results 1 to 7 of 7

Thread: ModelSim vsim-3039 fatal error

  1. #1
    Join Date
    Jan 2012
    Posts
    6
    Rep Power
    1

    Default ModelSim vsim-3039 fatal error

    Hi all,

    I would like to simulate a very simple design in SystemVerilog and to compare the results of RTL and gate level simulation. The RTL simulation works OK but if I launch the gate level simulation the ModelSim reports:
    # ALTERA version supports only a single HDL
    # ** Fatal: (vsim-3039) D:/... failed.
    # FATAL ERROR while loading design
    # Error loading design
    # Error: Error loading design

    Can anybody help me? Many thanks in advance.

  2. #2
    Join Date
    Aug 2005
    Location
    California
    Posts
    3,843
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    Modelsim simulates SystemVerilog just fine.

    What's with the D:/... in the error message? That doesn't look like a valid source file.

    This thread has some SystemVerilog code, you could try that

    http://www.alteraforum.com/forum/showthread.php?t=34391

    Cheers,
    Dave

  3. #3
    Join Date
    Jan 2012
    Posts
    6
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    dwh,
    the full line in question is:

    # ** Fatal: (vsim-3039) D:/1AlteraDsgn/Quart11/0SysVerilog/CombRepeater/CombRepeaterTF.sv(5): Instantiation of 'CombRepeater' failed.

    It contains the path to my design, I considered it not important.

    Jaromir Kolouch

  4. #4
    Join Date
    Aug 2005
    Location
    California
    Posts
    3,843
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    The error message tells you the problem: Instantiation of 'CombRepeater' failed.

    Have you compiled the source for 'CombRepeater'?

    Cheers,
    Dave

  5. #5
    Join Date
    Jan 2012
    Posts
    6
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    Dave,

    I have launched the Fitter (Place & Route) in the Task pane of Quartus GUI, passed OK, then I launched EDA Netlist Writer, and then Tools => Run EDA Simulation Tool => EDA Gate Level Simulation..., all of the Quartus GUI. I believe the Quartus ensures proper setting of ModelSim, here is corresponding part of the ModelSim log - I guess it shows all necessary:

    # vcom -93 -work work {CombRepeater.vho}
    # Model Technology ModelSim ALTERA vcom 6.6d Compiler 2010.11 Nov 2 2010
    # -- Loading package standard
    # -- Loading package std_logic_1164
    # -- Loading package vital_timing
    # -- Loading package vital_primitives
    # -- Loading package cycloneiv_atom_pack
    # -- Loading package cycloneiv_components
    # -- Compiling entity combrepeater
    # -- Compiling architecture structure of combrepeater
    #
    # vlog -sv -work work +incdir+D:/1AlteraDsgn/Quart11/0SysVerilog/CombRepeater {D:/1AlteraDsgn/Quart11/0SysVerilog/CombRepeater/CombRepeaterTF.sv}
    # Model Technology ModelSim ALTERA vlog 6.6d Compiler 2010.11 Nov 2 2010
    # -- Compiling module CombRepeaterTF
    #
    # Top level modules:
    # CombRepeaterTF
    #

  6. #6
    Join Date
    Aug 2005
    Location
    California
    Posts
    3,843
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    Modelsim-Altera only supports single-language compilation. Your example is compiling both VHDL and SystemVerilog.

    Change your project settings to generate a Verilog netlist (.vo) instead of VHDL netlist (.vho).

    Cheers,
    Dave

  7. #7
    Join Date
    Jan 2012
    Posts
    6
    Rep Power
    1

    Default Re: ModelSim vsim-3039 fatal error

    This is the valuable answer, I have changed settings to SystemVerilog and it is working OK.

    Thank you! Jaromir

Similar Threads

  1. Fatal error modelsim code 9 simulating 4 registers os 16bits each
    By taquionbcn in forum General Altera Discussion
    Replies: 4
    Last Post: April 18th, 2013, 08:06 AM
  2. Modelsim - trouble passing $ parameter from vsim to vlog
    By jacorn in forum Quartus II and EDA Tools Discussion
    Replies: 2
    Last Post: October 4th, 2011, 04:47 PM
  3. modelsim: (vsim-3053) Illegal output or inout port connection
    By ramanandn in forum Quartus II and EDA Tools Discussion
    Replies: 2
    Last Post: December 7th, 2010, 11:08 AM
  4. ALTIOBUF model sim Error: (vsim-3389)
    By kito in forum Quartus II and EDA Tools Discussion
    Replies: 2
    Last Post: March 30th, 2010, 06:12 PM
  5. modelsim vsim-3601 on counter
    By wangahrah in forum General Altera Discussion
    Replies: 5
    Last Post: December 10th, 2008, 06:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •