Results 1 to 3 of 3

Thread: syscalls for uCos-II / libc CycloneV SoC

  1. #1
    Join Date
    Jan 2014
    Posts
    13
    Rep Power
    1

    Question syscalls for uCos-II / libc CycloneV SoC

    Hi!

    I'm trying to compile uCos-II for Altera CycloneV SoC HPS using the mentor/codesourcery gcc toolchain. Linking currently fails because of missing systemcalls _exit _kill and _sbrk

    For Nios Alteraofficially ships alt_syscall.h in nios2eds/components/altera_hal/HAL/inc which defines for example _exit. Is there an official implementation for the ARM SoC ?


    Code:
    d:/altera/13.0sp1/embedded/host_tools/mentor/gnu/arm/baremetal/bin/../lib/gcc/arm-none-eabi/4.6.3/../../../../arm-none-eabi/lib\libc.a(lib_a-abort.o): In function `abort':
    abort.c:(.text+0x10): undefined reference to `_exit'
    d:/altera/13.0sp1/embedded/host_tools/mentor/gnu/arm/baremetal/bin/../lib/gcc/arm-none-eabi/4.6.3/../../../../arm-none-eabi/lib\libc.a(lib_a-signalr.o): In function `_kill_r':
    signalr.c:(.text+0x1c): undefined reference to `_kill'
    d:/altera/13.0sp1/embedded/host_tools/mentor/gnu/arm/baremetal/bin/../lib/gcc/arm-none-eabi/4.6.3/../../../../arm-none-eabi/lib\libc.a(lib_a-signalr.o): In function `_getpid_r':
    signalr.c:(.text+0x44): undefined reference to `_getpid'
    d:/altera/13.0sp1/embedded/host_tools/mentor/gnu/arm/baremetal/bin/../lib/gcc/arm-none-eabi/4.6.3/../../../../arm-none-eabi/lib\libc.a(lib_a-sbrkr.o): In function `_sbrk_r':
    sbrkr.c:(.text+0x18): undefined reference to `_sbrk'

  2. #2
    Join Date
    Aug 2004
    Location
    Texas Y'all
    Posts
    2,322
    Rep Power
    1

    Default Re: syscalls for uCos-II / libc CycloneV SoC

    Moving to the new "Other Operating Systems" forum. This is where all non-Linux OS related questions will go moving forward.

  3. #3
    Join Date
    Dec 2015
    Posts
    6
    Rep Power
    1

    Default Re: syscalls for uCos-II / libc CycloneV SoC

    i meet the same problems!is there anyone help

Similar Threads

  1. Is CycloneV real 6input lut?
    By leonqin in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 0
    Last Post: November 4th, 2013, 05:54 PM
  2. Libc Version : none
    By afaucon in forum Linux Forum
    Replies: 3
    Last Post: March 29th, 2010, 02:52 AM
  3. libc question
    By abg in forum Linux Forum
    Replies: 0
    Last Post: September 7th, 2006, 12:02 AM
  4. Problem with libc.a
    By janhendrik in forum General Discussion Forum
    Replies: 6
    Last Post: September 3rd, 2004, 11:06 AM
  5. libc.a error ?
    By janhendrik in forum General Software Forum
    Replies: 0
    Last Post: August 18th, 2004, 10:51 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •