Results 1 to 5 of 5

Thread: Cygheap issue with Nios II tools

  1. #1
    Join Date
    Feb 2009
    Location
    Salzburg/Austria
    Posts
    4
    Rep Power
    1

    Default Cygheap issue with Nios II tools

    Hello everyone,

    I'm facing an error from time to time when I execute nios2-xxx tools or when I start debugging in Nios II Eclipse.
    -> I'm getting a cygwin error as follows:

    Code:
          0 [main] perl (5284) C:\altera\13.0sp1\quartus\bin\cygwin\bin\perl.exe: *** fatal error - cygheap base mismatch detected - 0x612708D0/0x8208D0.
    This problem is probably due to using incompatible versions of the cygwin DLL.
    Search for cygwin1.dll using the Windows Start->Find/Search facility
    and delete all but the most recent version.  The most recent version *should*
    reside in x:\cygwin\bin, where 'x' is the drive on which you have
    installed the cygwin distribution.  Rebooting is also suggested if you
    are unable to find another cygwin DLL.
    /cygdrive/c/altera/13.0sp1/nios2eds/bin/sh_pl.sh: line 2:  5372 Segmentation fault      PERL5LIB=`cygpath -u "$SOPC_KIT_NIOS2/bin"` perl "${SH_PL:-$0.pl}" $@
    I've already found some posts in the net about this issue related to Win7 64bit, but didn't try them yet since I don't want to ruin my Quartus installation.
    Btw, I have no other cygwin installation on my system.

    Is there any solution to avoid that error and also avoid rebooting the PC?

    Best regards

  2. #2
    Join Date
    Jul 2009
    Posts
    71
    Rep Power
    1

    Default Re: Cygheap issue with Nios II tools

    Quote Originally Posted by zelenkaj View Post
    Hello everyone,

    I'm facing an error from time to time when I execute nios2-xxx tools or when I start debugging in Nios II Eclipse.
    -> I'm getting a cygwin error as follows:

    Code:
          0 [main] perl (5284) C:\altera\13.0sp1\quartus\bin\cygwin\bin\perl.exe: *** fatal error - cygheap base mismatch detected - 0x612708D0/0x8208D0.
    This problem is probably due to using incompatible versions of the cygwin DLL.
    Search for cygwin1.dll using the Windows Start->Find/Search facility
    and delete all but the most recent version.  The most recent version *should*
    reside in x:\cygwin\bin, where 'x' is the drive on which you have
    installed the cygwin distribution.  Rebooting is also suggested if you
    are unable to find another cygwin DLL.
    /cygdrive/c/altera/13.0sp1/nios2eds/bin/sh_pl.sh: line 2:  5372 Segmentation fault      PERL5LIB=`cygpath -u "$SOPC_KIT_NIOS2/bin"` perl "${SH_PL:-$0.pl}" $@
    I've already found some posts in the net about this issue related to Win7 64bit, but didn't try them yet since I don't want to ruin my Quartus installation.
    Btw, I have no other cygwin installation on my system.

    Is there any solution to avoid that error and also avoid rebooting the PC?

    Best regards
    I have it too... If someone has a solution for it....

  3. #3
    Join Date
    Feb 2009
    Location
    Salzburg/Austria
    Posts
    4
    Rep Power
    1

    Default Re: Cygheap issue with Nios II tools

    Hello everyone,

    maybe these links help to solve that issue?
    http://cygwin.com/ml/cygwin/2012-03/msg00010.html
    http://cygwin.wikia.com/wiki/Rebaseall

    Best regards!

  4. #4
    Join Date
    Jan 2016
    Posts
    1
    Rep Power
    1

    Default Re: Cygheap issue with Nios II tools

    Quote Originally Posted by medds7 View Post
    I have it too... If someone has a solution for https://peblueprint.com/bathmate-review the bathmate it....
    Those links didn't help zelenkaj. Is there anything else I can dod to get past this error message?
    Last edited by Ogden; May 24th, 2016 at 02:53 AM.

  5. #5
    Join Date
    Nov 2014
    Posts
    2
    Rep Power
    1

    Default Re: Cygheap issue with Nios II tools

    Hi,

    This error is still reproducible with QuartusII 14.0.

    nios2-elf-g++ -T'.../software/Fw_bsp_app/linker.x' -msys-crt0='.../software/Fw_bsp_app/obj/HAL/src/crt0.o' -msys-lib=hal_bsp -L.../software/liboplkcnapp-hostif -L.../software/Fw_bsp_app -Wl,-Map=Fw_host_app.map -O2 -g -Wall -mhw-div -mhw-mul -mno-hw-mulx -Wall -Wextra -pedantic -std=c99 -DNDEBUG -DCONFIG_CN -DALT_TCIMEM_SIZE=4096 -o Fw_host_app.elf obj/default//.../software/app.o obj/default//.../software/canbus.o obj/default//.../software/event.o obj/default/main.o obj/default/arp.o obj/default/gpio-nios2.o -loplkcnapp-hostif -lm
    nios2-elf-insert Fw_host_app.elf --thread_model hal --cpu_name host_0_cpu_1 --qsys true --simulation_enabled false --id xxxxx --sidp xxxxx --timestamp 1465982303 --stderr_dev host_0_jtag_uart_0 --stdin_dev host_0_jtag_uart_0 --stdout_dev host_0_jtag_uart_0 --sopc_system_name cnDualHostifGpio --quartus_project_dir "board" --jdi .../cn-dual-hostif-gpio.jdi --sopcinfo .../cnDualHostifGpio.sopcinfo
    0 [main] perl (6448) C:\altera\14.0\quartus\bin64\cygwin\bin\perl.exe: *** fatal error - cygheap base mismatch detected - 0x612708D0/0xBA08D0.
    This problem is probably due to using incompatible versions of the cygwin DLL.
    Search for cygwin1.dll using the Windows Start->Find/Search facility
    and delete all but the most recent version. The most recent version *should*
    reside in x:\cygwin\bin, where 'x' is the drive on which you have
    installed the cygwin distribution. Rebooting is also suggested if you
    are unable to find another cygwin DLL.
    /cygdrive/c/altera/14.0/nios2eds/bin/sh_pl.sh: line 2: 6916 Segmentation fault PERL5LIB="$(cd "${SOPC_KIT_NIOS2}" 2>/dev/null && pwd 2>/dev/null)/bin" perl "${SH_PL:-$0.pl}" $@

    Best regards,
    Romain

Similar Threads

  1. Programming epcs without Nios tools
    By SEILASER in forum General Discussion Forum
    Replies: 6
    Last Post: March 5th, 2015, 05:26 AM
  2. Location of C2H in NIOS 9.1 tools?
    By mikebray in forum Nios II C-to-Hardware Acceleration
    Replies: 6
    Last Post: December 23rd, 2010, 02:03 PM
  3. Nios II development tools
    By Cris72 in forum Nios Forum
    Replies: 1
    Last Post: July 6th, 2010, 02:12 AM
  4. Nios' TCL Tools
    By David_Cai in forum General Software Forum
    Replies: 0
    Last Post: December 13th, 2005, 05:05 PM
  5. What's wrong and How to upgrade my nios-gnu-tools?
    By LiangYi in forum General Software Forum
    Replies: 0
    Last Post: January 11th, 2005, 12:17 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •