Results 1 to 10 of 10

Thread: Some problems about altera_pll on cyclone V device

  1. #1
    Join Date
    Apr 2013
    Posts
    31
    Rep Power
    1

    Default Some problems about altera_pll on cyclone V device

    Hello everyone,

    I just met a problem about altera_pll on my cyclone V board. There is a 5CEFA4F23C8 FPGA on my board and the FPGA is conneted to a crystal oscillator via a clock input pin.

    The crystal frequency is 50MHz and i want to generate an 100MHz signal but the output is nothing(zero).

    I tested the reset signal and the crystal and found the reset is logic high(3.3V) and the crystal is 50MHz sine wave. Further more, I also tested the "locked" signal of the altera_pll and found it low.

    Is there anyone who has met similar problem and can give me some advice?

    Thanks a lot.
    Regards.

    Alex
    Last edited by darlingsun; August 8th, 2016 at 07:18 PM.

  2. #2
    Join Date
    Jan 2012
    Posts
    8
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    did you check RREF_TL on your board?

    from pin Connection Guide:
    Reference Pins

    RREF_TL Input - Reference resistor for transceiver and PLL

    If any PLL, REFCLK pin, or transceiver channel is used, you must connect each RREF pin on that
    side of the device through its own individual 2.0-kΩ +/- 1% resistor to GND. Otherwise, you may
    connect each RREF pin on that side of the device directly to GND. In the PCB layout, the trace
    from this pin to the resistor needs to be routed so that it avoids any aggressor signals.

  3. #3
    Join Date
    Sep 2015
    Posts
    138
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Quote Originally Posted by lars_g View Post
    did you check RREF_TL on your board?

    from pin Connection Guide:
    Reference Pins

    RREF_TL Input - Reference resistor for transceiver and PLL

    If any PLL, REFCLK pin, or transceiver channel is used, you must connect each RREF pin on that
    side of the device through its own individual 2.0-kΩ +/- 1% resistor to GND. Otherwise, you may
    connect each RREF pin on that side of the device directly to GND. In the PCB layout, the trace
    from this pin to the resistor needs to be routed so that it avoids any aggressor signals.
    Also, make sure that the PLL settings and pin mappings are correct. I hate to state the obvious, but it is possible that the wrong input pin is selected for the PLL input clock or the PLL is set for a different input clock frequency.

  4. #4
    Join Date
    Apr 2013
    Posts
    31
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Thank you for your advice, derim。
    I just confirmed the input pins and found it correctly connected to the dedicated CLK3_P pin , so as my teammates.
    If I use the external clock directly, the clock is OK. But if only the altera_pll exists, the system fails.

  5. #5
    Join Date
    Sep 2015
    Posts
    138
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Quote Originally Posted by darlingsun View Post
    Thank you for your advice, derim。
    I just confirmed the input pins and found it correctly connected to the dedicated CLK3_P pin , so as my teammates.
    If I use the external clock directly, the clock is OK. But if only the altera_pll exists, the system fails.
    Additional obvious check: is the reset pin pulled low? The PLL expects an active-high reset, not active low. In addition, is the PLL set to auto-lock in the settings?

  6. #6
    Join Date
    Apr 2013
    Posts
    31
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Thank you and finally found the RREF_TL pin is unconnected. I think it may be the real reason.


    Quote Originally Posted by lars_g View Post
    did you check RREF_TL on your board?

    from pin Connection Guide:
    Reference Pins

    RREF_TL Input - Reference resistor for transceiver and PLL

    If any PLL, REFCLK pin, or transceiver channel is used, you must connect each RREF pin on that
    side of the device through its own individual 2.0-kΩ +/- 1% resistor to GND. Otherwise, you may
    connect each RREF pin on that side of the device directly to GND. In the PCB layout, the trace
    from this pin to the resistor needs to be routed so that it avoids any aggressor signals.

  7. #7
    Join Date
    Mar 2015
    Posts
    77
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    I faced the same problem and the PLL was not locking. The RREF_TL was left floating. The issue was partially solved after fixing this floating pin.

  8. #8
    Join Date
    Apr 2013
    Posts
    31
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Quote Originally Posted by sherif123 View Post
    I faced the same problem and the PLL was not locking. The RREF_TL was left floating. The issue was partially solved after fixing this floating pin.
    Thank you for your advice, Sherif. Does your PLL work now?

    You mentioned that your issur has been partially solved. I wonder what issue has not been solved now.

  9. #9
    Join Date
    Apr 2013
    Posts
    31
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    Thank you for your advice, Sherif. Does your PLL work now?

    You mentioned that your issur has been partially solved. I wonder what issue has not been solved now.

  10. #10
    Join Date
    Mar 2015
    Posts
    77
    Rep Power
    1

    Default Re: Some problems about altera_pll on cyclone V device

    The PLL issue was solved and it was working as expected.
    The chip was new to me and it is a custom board not an evaluation one. So I had a lot of things to test.
    But anyway, everything is good for me now. That RREF_TL caused me some hard time.

Similar Threads

  1. altera_pll + altlvds_rx = problems with fitting
    By AlexanderBolm in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 3
    Last Post: February 22nd, 2016, 02:53 AM
  2. Quartus v14.0 Altera_PLL IP targeting Cyclone V (5CEFA7) does not lock
    By cperezmit06 in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 2
    Last Post: March 26th, 2015, 07:25 AM
  3. cyclone v altera_pll warning
    By mrityunjaynath in forum General Altera Discussion
    Replies: 0
    Last Post: December 1st, 2014, 08:48 PM
  4. Replies: 1
    Last Post: April 25th, 2013, 04:36 AM
  5. altera_pll megafunction device speed grade values
    By fpgabuilder in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 0
    Last Post: April 2nd, 2013, 03:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •