Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: UART 16550 vs standard UART

  1. #11
    Join Date
    Nov 2016
    Posts
    12
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Quote Originally Posted by aaronchng View Post
    Have you tried if JTAG UART works?
    No. I had the "standard" UART in before, got my application working, but needed one with a FIFO. So tried to get the 16550-UART to work, without success.
    What I'm really trying is to get the RSU working (application note 741), so my NIOS system is pretty simple, basically using the AN-741 template, and replacing
    the UART in it with the 16550-UART. Any chance anybody else can try it?

  2. #12
    Join Date
    Nov 2016
    Posts
    12
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Quote Originally Posted by e2000 View Post
    No. I had the "standard" UART in before, got my application working, but needed one with a FIFO. So tried to get the 16550-UART to work, without success.
    What I'm really trying is to get the RSU working (application note 741), so my NIOS system is pretty simple, basically using the AN-741 template, and replacing
    the UART in it with the 16550-UART. Any chance anybody else can try it?
    And, all of this is done on MAX10, and the Altera DK-DEV-10M50 board...

  3. #13
    Join Date
    Feb 2016
    Posts
    21
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Sorry that I am confused. For your working design, you must have seen the RS232 UART in BSP setting. But you are saying that you get "none".
    So which is correct?

  4. #14
    Join Date
    Nov 2016
    Posts
    12
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Quote Originally Posted by aaronchng View Post
    Sorry that I am confused. For your working design, you must have seen the RS232 UART in BSP setting. But you are saying that you get "none".
    So which is correct?
    No problem ;-)

    what I did:

    a.) used the RSU AN741 template, generated a NIOS system, with an UART, which was working, I could "see" the UART in the BSP-Editor.
    However, the performance for our application wasn't sufficient, so we tried to install the 16550-UART, which has big FIFOs, which we thought would
    improve the performance on the serial line.

    b.) We added the a_16550_uart to our QSYS design, but it doesn't show up in the BSP editor. Only the "standard" uart_0 is there.

    c.) we removed the standard uart_0 from the QSYS, and now there aren't any UART anymore to select in the BSP editor.

    So, what are we doing wrong, that the a_16550_uart doesn't show up in the BSP editor, as an UART for stdin/stdout/stderr?

    thanks!

  5. #15
    Join Date
    Feb 2016
    Posts
    21
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    I have tried to replicate your issue and observed the same behavior.
    Most likely this is due to the HAL driver for 16550 UART is not ready for such BSP configuration

  6. #16
    Join Date
    Nov 2016
    Posts
    12
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Quote Originally Posted by aaronchng View Post
    I have tried to replicate your issue and observed the same behavior.
    Most likely this is due to the HAL driver for 16550 UART is not ready for such BSP configuration
    Thanks a lot for trying!
    I was going nuts, as I thought I'm doing something wrong, and in other posts it sounded to easy ;-)

    Altera: any chance to fix this?

    Thanks again!

  7. #17
    Join Date
    Feb 2016
    Posts
    21
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    This issue has been logged. Let's look forward to the fix in near future

  8. #18
    Join Date
    Nov 2016
    Posts
    12
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    Quote Originally Posted by aaronchng View Post
    This issue has been logged. Let's look forward to the fix in near future
    Excellent!
    Will there be a patch,
    or do we have to wait for 16.3 or 17.0?
    Thanks!

  9. #19
    Join Date
    Feb 2016
    Posts
    21
    Rep Power
    1

    Default Re: UART 16550 vs standard UART

    The delivery milestone is undecided at the moment.

Similar Threads

  1. Replies: 3
    Last Post: August 26th, 2015, 12:25 PM
  2. 16550 UART to Avalon
    By alterahenry in forum General Altera Discussion
    Replies: 11
    Last Post: January 9th, 2011, 11:47 PM
  3. Replies: 2
    Last Post: May 30th, 2008, 01:03 AM
  4. drivers for opencores 16550 Uart
    By mountain8848 in forum Linux Forum
    Replies: 0
    Last Post: December 20th, 2005, 03:13 AM
  5. UART 16550 from OpenCores
    By VLorenzo in forum General Discussion Forum
    Replies: 1
    Last Post: November 15th, 2005, 12:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •