Results 1 to 6 of 6

Thread: "program" missing from OpenCL RTE for DE1 SoC?

  1. #1
    Join Date
    Mar 2011
    Posts
    4
    Rep Power
    1

    Default "program" missing from OpenCL RTE for DE1 SoC?

    Hi -- I'm trying to run the hello_world example from http://www.terasic.com.tw/attachment...OpenCL_v02.pdf
    However when I type 'aoc program hello_world.aocx' it throws following error:
    program: The Altera Linux SoC Runtime Environment for OpenCL is incomplete: Can't find /home/root/opencl_arm32_rte/host/arm32/bin/program

    If I run ./hello_world, it seems to work fine.

    I'm using the BSP for 16.0 --> http://www.terasic.com/downloads/cd-...l_BSP_16.0.zip

    The vector_add demo also fails to work and quites with an invalid binary error

    Initializing OpenCL
    Platform: Altera SDK for OpenCL
    Using 1 device(s)
    de1soc_sharedonly : Cyclone V SoC Development Kit
    Using AOCX: vectorAdd.aocx
    ERROR: CL_INVALID_BINARY
    Location: ../common/src/AOCL_Utils.cpp:391
    Failed to create program with binary

  2. #2
    Join Date
    Mar 2011
    Posts
    4
    Rep Power
    1

    Default Re: "program" missing from OpenCL RTE for DE1 SoC?

    Terasic has released a new BSP with the updated aocl utilities. This one ships with program in the correct location.\
    http://mail.terasic.com.cn/~jmlei/de1-soc/de1soc_opencl_BSP_16.0.zip

    Quote Originally Posted by nachiket View Post
    Hi -- I'm trying to run the hello_world example from http://www.terasic.com.tw/attachment...OpenCL_v02.pdf
    However when I type 'aoc program hello_world.aocx' it throws following error:
    program: The Altera Linux SoC Runtime Environment for OpenCL is incomplete: Can't find /home/root/opencl_arm32_rte/host/arm32/bin/program

    If I run ./hello_world, it seems to work fine.

    I'm using the BSP for 16.0 --> http://www.terasic.com/downloads/cd-...l_BSP_16.0.zip

    The vector_add demo also fails to work and quites with an invalid binary error

    Initializing OpenCL
    Platform: Altera SDK for OpenCL
    Using 1 device(s)
    de1soc_sharedonly : Cyclone V SoC Development Kit
    Using AOCX: vectorAdd.aocx
    ERROR: CL_INVALID_BINARY
    Location: ../common/src/AOCL_Utils.cpp:391
    Failed to create program with binary

  3. #3
    Join Date
    Feb 2017
    Location
    Seoul
    Posts
    1
    Rep Power
    1

    Default Re: "program" missing from OpenCL RTE for DE1 SoC?

    Hi, nachiket
    If you do not mind, can I find the download address?

  4. #4
    Join Date
    Mar 2017
    Posts
    2
    Rep Power
    1

    Default Re: "program" missing from OpenCL RTE for DE1 SoC?

    hi
    i have same problem with de1-soc on "BSP(Board Support Package) for Altera SDK OpenCL 16.0" linux image file.
    bsp version 16.0

    how can i solve it?
    thanks

  5. #5
    Join Date
    Mar 2017
    Posts
    2
    Rep Power
    1

    Default Re: "program" missing from OpenCL RTE for DE1 SoC?

    Please help me ...

  6. #6
    Join Date
    Jan 2017
    Posts
    335
    Rep Power
    1

    Default Re: "program" missing from OpenCL RTE for DE1 SoC?

    Quote Originally Posted by pouya530 View Post
    Please help me ...
    If you have already tried the latest BSP from Terasic and already read and followed their documents and you still cannot get it to work; you should contact Terasic directly. They are obliged to help you.

Similar Threads

  1. Replies: 0
    Last Post: March 8th, 2015, 06:04 PM
  2. error:Port "enable" does not exist in primitive "latch" of instance "u0"
    By MR_Naidu in forum Quartus II and EDA Tools Discussion
    Replies: 5
    Last Post: February 25th, 2012, 10:36 AM
  3. Error: Port "i1" does not exist in primitive "nand2" of instance "g2"
    By alizadeharand in forum Quartus II and EDA Tools Discussion
    Replies: 1
    Last Post: July 24th, 2011, 10:23 PM
  4. In Quartus Programmer, does "Program an EPC16 with POF" include a "Verify"?
    By mandana in forum Quartus II and EDA Tools Discussion
    Replies: 0
    Last Post: April 13th, 2010, 01:32 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •