Results 1 to 4 of 4

Thread: why different simulation outputs modelsim and simulation wave editor for ring osc..

  1. #1
    Join Date
    Apr 2018
    Posts
    2
    Rep Power
    1

    Default why different simulation outputs modelsim and simulation wave editor for ring osc..

    Hello to everyone.

    I apologize for disturbing you. I am trying to modeling ring oscillator in FPGA. You can see my design details in attached photo files.


    • At first modeled it schematically(photo1) then i run timing simulation it via simulation waveform editor/university program tools.

    With this method i can see timing delays outputs(photo2 and photo3). when simulation results expanded outputs


    • Then i want to see my outputs delays in modelsim. For this purpose i convert my schematic design to .vhd file(file>create/update>create hdl design...). Then i use gate level simulation tool in quartus for modelsim. .... When I look at the results(photo4-->results, photo5-->zooming results) there is a problem.

    The outputs of modelsim and university program quite different from each other. In modelsim the delay for the next output from the previous one logic delays periodically
    increasing(photo 4 photo 5). But in simulation waveform editor/university program ring oscillator outputs logic delays not periodic(photo 2 photo3).
    What is the main reason for this situation and which result is correct? i couldnt decided.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2017
    Posts
    488
    Rep Power
    1

    Default Re: why different simulation outputs modelsim and simulation wave editor for ring osc

    Hi,

    Can you share the .bdf file?

    Best Regards,
    Anand Raj Shankar
    (This message was posted on behalf of Intel Corporation)

  3. #3
    Join Date
    Apr 2018
    Posts
    2
    Rep Power
    1

    Default Re: why different simulation outputs modelsim and simulation wave editor for ring osc

    Ok, thanks for your interest, i sent it.
    Attached Files Attached Files

  4. #4
    Join Date
    Nov 2017
    Posts
    488
    Rep Power
    1

    Default Re: why different simulation outputs modelsim and simulation wave editor for ring osc

    Hi,

    Yes, In simulation result we can see the difference.
    This is because of the conversion(.bdf to .vhd/.v) which we are doing.
    The conversion is adding some extra delay/logic which can be seen in RTL viewer because of which we are getting the different results.

    Best Regards,
    Anand Raj Shankar
    (This message was posted on behalf of Intel Corporation)

Similar Threads

  1. Unable to run simulation in Simulation Waveform Editor
    By matthewj8489 in forum Quartus II and EDA Tools Discussion
    Replies: 1
    Last Post: June 18th, 2014, 05:25 AM
  2. Sine wave simulation
    By hsv in forum General Altera Discussion
    Replies: 2
    Last Post: January 8th, 2013, 04:24 AM
  3. ModelSim RTL simulation works, now gate-level simulation
    By goretkin in forum Quartus II and EDA Tools Discussion
    Replies: 0
    Last Post: June 1st, 2011, 07:45 AM
  4. Several little questions about VHDL and its simulation wave
    By JohnRita in forum General Altera Discussion
    Replies: 4
    Last Post: December 6th, 2009, 05:44 PM
  5. I'M puzzled. why simulation wave is incorrect!
    By 1521 in forum Quartus II and EDA Tools Discussion
    Replies: 4
    Last Post: January 20th, 2008, 02:44 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •