Results 1 to 2 of 2

Thread: How do I connect 4, 4-bit, busses each to an LPM_MUX?

  1. #1
    Join Date
    Jul 2018
    Posts
    1
    Rep Power
    1

    Default How do I connect 4, 4-bit, busses each to an LPM_MUX?

    I am trying to employ busses and LPM_MUX to simplify an ALU design. My wires are all replaced with bus wires, but I do not understand how to connect each of my 4 inputs to their corresponding input lines on the mux. The first input is /A, the second is A+B, and the last two are just placeholders until I can get the first two working.

    I have tried many different bracketing methods, but there are error messages saying I have width mismatches. Others say something like "node 'DATA3_3' does not have input."

    Similar issues are arising with the LPM_OR, but I suspect fixing one will fix both. (I am relatively new to Quartus, and I'm trying to teach myself how to use the busses and LPM functions.)
    Attached Images Attached Images

  2. #2
    Join Date
    Feb 2018
    Posts
    142
    Rep Power
    1

    Default Re: How do I connect 4, 4-bit, busses each to an LPM_MUX?

    Hi,
    (I am relatively new to Quartus, and I'm trying to teach myself how to use the busses and LPM functions.)
    That`s great.
    Here AHDL bus notation is used to create multiple pins so just give name( aabar[3..0],aORRSLT[3..0],C[3..0],D[3..0])) to the wires by right click-> Properties.
    You can use lpm_inv & lpm_or Magafunctions as well, Check the screenshot for reference.

    Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

    Best Regards
    Vikas Jathar
    (This message was posted on behalf of Intel Corporation)
    Attached Images Attached Images

Similar Threads

  1. MegaWizard with LPM_MUX runs extremely slowly and is unusable
    By integrator in forum Quartus II and EDA Tools Discussion
    Replies: 8
    Last Post: June 8th, 2018, 10:34 PM
  2. LPM_MUX verilog files
    By paragpurankar in forum Quartus II and EDA Tools Discussion
    Replies: 1
    Last Post: January 16th, 2014, 10:04 PM
  3. problem of lpm_mux in megafunction
    By lgeorge123 in forum General Altera Discussion
    Replies: 12
    Last Post: May 17th, 2013, 03:03 AM
  4. Multiplexing bidirectionnal busses
    By joeka in forum General Altera Discussion
    Replies: 3
    Last Post: August 29th, 2011, 11:52 PM
  5. Problem with LPM_MUX
    By manannan in forum Quartus II and EDA Tools Discussion
    Replies: 3
    Last Post: July 12th, 2010, 05:17 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •