Results 1 to 4 of 4

Thread: Quartus / Modelsim Compile Order

  1. #1
    Join Date
    Jun 2007
    Posts
    11
    Rep Power
    1

    Default Quartus / Modelsim Compile Order

    Hi,

    I am wondering if anybody can tell me how to set the compile order for modelsim.
    I have created a small test project in VHDL where I directly instantiate an
    entity (without component declaration VHDL-93).

    Code:
    entity comp_inst is
    	port 
    	(
    		a	: in std_logic;
    		y	: out std_logic
    	);
    end entity;
    
    architecture rtl of comp_inst is
    begin
    	U1: entity work.my_not(rtl) port map (a, y);
    end rtl;
    When I start Modelsim from Quartus via the "EDA RTL Simulation" command,
    Quartus is generating a .do script with the following compile order:

    Code:
    vcom -93 -work work {C:/altera/work/comp_inst/comp_inst.vhd}
    vcom -93 -work work {C:/altera/work/comp_inst/my_not.vhd}
    Modelsim is generating the following error message during compilation.
    Code:
    # vcom -93 -work work {C:/altera/work/comp_inst/comp_inst.vhd}
    # Model Technology ModelSim ALTERA vcom 6.4a Compiler 2008.08 Oct 22 2008
    # -- Loading package standard
    # -- Loading package std_logic_1164
    # -- Compiling entity comp_inst
    # -- Compiling architecture rtl of comp_inst
    # ** Error: (vcom-11) Could not find work.my_not.
    # ** Error: C:/altera/work/comp_inst/comp_inst.vhd(14): (vcom-1195) Cannot find expanded name "work.my_not".
    # ** Error: C:/altera/work/comp_inst/comp_inst.vhd(14): Unknown expanded name.
    # ** Error: C:/altera/work/comp_inst/comp_inst.vhd(15): VHDL Compiler exiting
    # ** Error: C:/altera/90/modelsim_ase/win32aloem/vcom failed.
    # Error in macro ./comp_inst_run_msim_rtl_vhdl.do line 8
    # C:/altera/90/modelsim_ase/win32aloem/vcom failed.
    #     while executing
    # "vcom -93 -work work {C:/altera/work/comp_inst/comp_inst.vhd}"
    If I swap the compile order of the two entities and restart the *.do script within
    Modelsim everything is working fine.
    Anyway on the next start Quartus has overwritten the modified *.do script.
    Is there any way to force quartus to generate a script with the right compile order?

    Thanks!

    BTW I am using Quartus 9.0 Web Edition and Modelsim Altera Starter Edition 6.4a

  2. #2
    Join Date
    Oct 2008
    Location
    UK
    Posts
    2,765
    Rep Power
    1

    Default Re: Quartus / Modelsim Compile Order

    try "add files" to project in Quartus menu, in the order you want

  3. #3
    Join Date
    Jun 2007
    Posts
    11
    Rep Power
    1

    Default Re: Quartus / Modelsim Compile Order

    I changed the order in "Projekt - Add/Remove files in Projekt..." and also tried to change the order in "Project Navigator - Files" sheet but the order in the .do script does not change.
    Any other idea?

  4. #4
    Join Date
    Jun 2007
    Posts
    11
    Rep Power
    1

    Default Re: Quartus / Modelsim Compile Order

    It works if you change the order in the "Project Navigator - Files" sheet and afterwards start the "analysis & synthesis" process.
    Thanks for the help!

Similar Threads

  1. Quartus/ModelSim
    By rob in forum Quartus II and EDA Tools Discussion
    Replies: 1
    Last Post: December 17th, 2008, 11:05 PM
  2. Dual port RAM in Quartus II 7.2, different behavior on ModelSim than Quartus simulato
    By AAS_2006 in forum Quartus II and EDA Tools Discussion
    Replies: 22
    Last Post: August 21st, 2008, 04:55 PM
  3. Best Computer for Quartus Compile Times...
    By tpinkney in forum Quartus II and EDA Tools Discussion
    Replies: 9
    Last Post: July 28th, 2008, 07:36 AM
  4. how to compile vhdl package in quartus ii
    By DavidWang in forum Quartus II and EDA Tools Discussion
    Replies: 1
    Last Post: September 6th, 2007, 12:02 AM
  5. Quartus compile message options?
    By waster in forum Quartus II and EDA Tools Discussion
    Replies: 3
    Last Post: May 29th, 2007, 07:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •