Results 1 to 1 of 1

Thread: Video flickering using DMA Controller with D5M on DE2i-150

  1. #1
    Join Date
    Mar 2017
    Posts
    1
    Rep Power
    1

    Exclamation Video flickering using DMA Controller with D5M on DE2i-150

    I'm having trouble when using DMA Controller to buffer video stream captured from D5M on DE2i-150.

    The video will get flickering if I buffer video over 320x240x16bit resolution. However, 160x480x16bit resolution works fine.

    I think the problem associates with the RAM, both SDRAM and SSRAM. I can't find a configuration for these RAMs to get it work.

    I wish to make it works at 640x480x16bit resolution.

    Results from buffering with 320x240x16bit


    Results from buffering with 160x480x16bit
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by longtomo; May 18th, 2017 at 08:50 AM. Reason: Add explainatory images

Similar Threads

  1. DE2i-150
    By Nilofar in forum General Altera Discussion
    Replies: 0
    Last Post: April 20th, 2017, 05:50 AM
  2. Output Linux´s Video to VGA controller in FPGA Fabric through AXI on CV SoC
    By nachodizz990 in forum General Altera Discussion
    Replies: 18
    Last Post: January 23rd, 2016, 05:03 AM
  3. [DE0 Nano] Image is flickering when displayed on LCD
    By cromero in forum General Altera Discussion
    Replies: 0
    Last Post: March 19th, 2014, 05:15 PM
  4. Replies: 1
    Last Post: March 6th, 2013, 11:06 AM
  5. SSRAM Video buffer for VGA Controller VHDL
    By Mat in forum IP Discussion
    Replies: 0
    Last Post: March 27th, 2011, 11:26 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •