Results 1 to 6 of 6

Thread: bsp-create-settings --type spl error

  1. #1
    Join Date
    Oct 2012
    Posts
    8
    Rep Power
    1

    Default bsp-create-settings --type spl error

    i have installed SoC EDS 17.0 on Ubuntu 14.04.5 LTS x64, but path for bsp-create-settings was not set in envirment variable
    Code:
    $ bsp-create-settings
    bsp-create-settings: command not found
    so i export as follows
    Code:
    $export PATH=$PATH:/home/soft/intelFPGA_pro/17.0/embedded/host_tools/altera/preloadergen/
    then tried again

    Code:
    $bsp-create-settings \
            --type spl \
            --bsp-dir software/preloader \
            --preloader-settings-dir "hps_isw_handoff/soc_system_hps_0" \
            --settings software/preloader/settings.bsp \
            --set spl.boot.WATCHDOG_ENABLE false --set spl.boot.SDRAM_SCRUBBING true
    
    INFO: Creating BSP settings file...
    INFO: nios2-bsp-create-settings --type spl --bsp-dir software/preloader  --preloader-settings-dir hps_isw_handoff/soc_system_hps_0 --settings  software/preloader/settings.bsp --set spl.boot.WATCHDOG_ENABLE false  --set spl.boot.SDRAM_SCRUBBING true 
    SEVERE: Available BSP type values for the --type argument are: [uboot, uefi]
    SEVERE: Available BSP type values for the --type argument are: [uboot, uefi]
    SEVERE: nios2-bsp-create-settings failed.
    make: *** [stamp/preloader.stamp] Error 1

    i dont undertand the error exactly, i think its related to --type spl option. can anyone please tell me how to overcome this error?

  2. #2
    Daixiwen is offline Moderator **Forum Master**
    Join Date
    May 2008
    Location
    Norway
    Posts
    4,508
    Rep Power
    1

    Default Re: bsp-create-settings --type spl error

    Yes it looks like bsp-create-settings is missing the spl type. what do you get when you execute
    Code:
    bsp-create-settings --type \?
    (with the question mark)? For me it says
    Code:
    Available BSP types are: [spl, uboot, uefi]
    It could be that your environment is not set up correctly. I don't think that setting the PATH is enough, Altera provides a script that sets up the environment for you. I don't remember where it comes from, but on my installation I've copied it to /usr/local/bin. Here are the contents:
    Code:
    #!/bin/bash
    ############################################################
    #                                                          #
    # Altera SoC Embedded Command Shell                        #
    #                                                          #
    #                                                          #
    # Copyright (c) 2016 Altera Corporation                    #
    # All Rights Reserved.                                     #
    #                                                          #
    ############################################################
    
    _SOCEDS_ROOT="/usr/local/intelFPGA/16.1/embedded"
    
    export SOCEDS_DEST_ROOT="${_SOCEDS_ROOT}"
    
    source "${_SOCEDS_ROOT}/env.sh"
    
    ############################################################
    
    
    unset _SOCEDS_ROOT
    (just replace _SOCEDS_ROOT with wherever your Quartus version is installed). Has you see it defines a root path for the SOC EDS and executes a script there. This script sets up a bunch of environment variables that are required by some tools.

    I have never created a preloader configuration from the command line myself though, I've always used the bsp editor (type bsp-editor from your command line)
    Definition of a man-year: 730 people trying to finish the project before lunch

  3. #3
    Join Date
    Oct 2012
    Posts
    8
    Rep Power
    1

    Default Re: bsp-create-settings --type spl error

    Quote Originally Posted by Daixiwen View Post
    Yes it looks like bsp-create-settings is missing the spl type. what do you get when you execute
    Code:
    bsp-create-settings --type \?
    (with the question mark)? For me it says
    Code:
    Available BSP types are: [spl, uboot, uefi]
    for me it shows
    Code:
    $ bsp-create-settings --type \?
    
    Available BSP types are: [uboot, uefi]
    Quote Originally Posted by Daixiwen View Post
    It could be that your environment is not set up correctly. I don't think that setting the PATH is enough, Altera provides a script that sets up the environment for you. I don't remember where it comes from, but on my installation I've copied it to /usr/local/bin. Here are the contents:
    i have allready in Soc Command Shell by
    $embedded/embedded_command_shell.sh
    Code:
    #!/bin/bash
    ############################################################
    #                                                          #
    # Altera SoC Embedded Command Shell                        #
    #                                                          #
    #                                                          #
    # Copyright (c) 2017 Altera Corporation                    #
    # All Rights Reserved.                                     #
    #                                                          #
    ############################################################
    
    
    ############################################################
    #
    # Get the Root SOCEDS directory
    #
    
    if [ -n "${COMSPEC}" ]; then
        _IS_WINDOWS=1
     
        if [ "${SOCEDS_DESTROY_PATH}" == "1" ]; then	
            export ORIGINAL_PATH="${PATH}"
            PATH="/bin:/usr/bin"
        fi
    fi
    
    if [ "${_IS_WINDOWS}" = "1" ] && [ -n "$(which cygpath 2>/dev/null)" ]; then
        _IS_CYGWIN=1
    fi
    
    _SOCEDS_ROOT=$(cd "$(dirname "${0}")" && echo "$(pwd 2>/dev/null)")
    
    if [ ! -d "${_SOCEDS_ROOT}" ]; then
        echo "${_SOCEDS_ROOT} not found. Invalid or corrupt SOCEDS Install" 1>&2
        exit 1
    fi
    
    export SOCEDS_DEST_ROOT="${_SOCEDS_ROOT}"
    if [ "${_IS_CYGWIN}" == "1" ]; then
        SOCEDS_DEST_ROOT="$(cygpath -m "${SOCEDS_DEST_ROOT}" 2>/dev/null)"
    fi
    
    source "${_SOCEDS_ROOT}/env.sh"
    
    ############################################################
    
    
    unset _SOCEDS_ROOT
    unset _IS_WINDOWS
    unset _IS_CYGWIN
    
    
    if [ -n "$*" ]; then
        exec "$@"
    else
        echo "------------------------------------------------"
        echo "Altera Embedded Command Shell"
        echo
        echo "Version 17.0 [Build 290]"
        echo "------------------------------------------------"
    
        # Use bash --norc to get a clean shell
        # Use bash --rcfile <bashrc> to for a user rcfile
        # Default to using ~/.bashrc
        exec bash
    fi

    Quote Originally Posted by Daixiwen View Post
    I have never created a preloader configuration from the command line myself though, I've always used the bsp editor (type bsp-editor from your command line)
    as per your suggestion i tried for bsp-editor, but as i create new HPS bsp, there is no drop down option for 'Cyclone V' and also the ok button is disable on selection of preloader setting directory.

  4. #4
    Daixiwen is offline Moderator **Forum Master**
    Join Date
    May 2008
    Location
    Norway
    Posts
    4,508
    Rep Power
    1

    Default Re: bsp-create-settings --type spl error

    So if it is not your environment, could it be that a part of the installation is missing? When you installed Quartus, did you also install the Cyclone V device and the Soc EDS? All the devices are in a separate installation, and so does the Soc EDC if I remember correctly.
    Definition of a man-year: 730 people trying to finish the project before lunch

  5. #5
    Join Date
    Oct 2012
    Posts
    8
    Rep Power
    1

    Default Re: bsp-create-settings --type spl error

    Thanks for reply,

    Quote Originally Posted by Daixiwen View Post
    So if it is not your environment, could it be that a part of the installation is missing?
    For safe side, I have reinstall the Soc EDS. But the result is same.

    Quote Originally Posted by Daixiwen View Post
    When you installed Quartus, did you also install the Cyclone V device and the Soc EDS? All the devices are in a separate installation, and so does the Soc EDC if I remember correctly.
    yes i have installed Cyclone V device and the Soc EDS with Quartus, I can build Quartus project for cyclone V in current installation.

  6. #6
    Join Date
    Mar 2018
    Posts
    1
    Rep Power
    1

    Default Re: bsp-create-settings --type spl error

    same here. when starting bsp-editor from eds environment, it displays:
    INFO: Initializing BSP components...
    2018.03.19.10:20:48 Conan.addPluginPath:477 (3) adding search path "/home/**/intelFPGA_lite/17.1/quartus/sopc_builder/bin/root_components.ipx" as "/home/**/intelFPGA_lite/17.1/quar
    - tus/sopc_builder/bin/root_components.ipx" because ipx file


    looks like the path is broken

Similar Threads

  1. nios2-bsp-create-settings failed error
    By emrebulbul23 in forum General Discussion Forum
    Replies: 0
    Last Post: February 11th, 2017, 04:04 AM
  2. Error (10928): SystemVerilog error ... enum type cannot be assigned to enum type
    By dmitryl_amarel in forum Quartus II and EDA Tools Discussion
    Replies: 0
    Last Post: January 19th, 2017, 12:50 AM
  3. VHDL Type Mismatch error indexed name returns a value whose type does not match
    By programmingzeal in forum Quartus II and EDA Tools Discussion
    Replies: 8
    Last Post: May 8th, 2012, 04:16 AM
  4. Error in nios2-bsp-create-settings
    By dcaradiocomp in forum Quartus II and EDA Tools Discussion
    Replies: 0
    Last Post: January 5th, 2011, 01:50 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •