Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: helloworld issue on arria10Gx development kit

  1. #21
    Join Date
    Feb 2018
    Posts
    16
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Quote Originally Posted by HRZ View Post
    Then there must be something wrong with your environmental variables somewhere. If the compiled host code is detecting your CPU, but not your FPGA, it means it is being compiled against some SDK other than Altera's, or that your FPGA is not being detected and hence, the host code is using the CPU. Have you made sure your board is detected correctly? e.g. does your board pass "aocl diagnose"?
    Hello HRZ,

    With multiple trials of reboot and "sudo jtagconfig", able to get on-board JTAG interface. Host commands lsusb, lspci and jtagconfig works and lists Arria10Gx board. But now when I run application its giving different error.

    mobiliya@mobiliya:~/intelFPGA_pro/17.1/quartus/bin$ jtagconfig
    1) USB-BlasterII [3-13]
    02E660DD 10AX115H1(.|E2|ES)/10AX115H2/..
    020A40DD 5M(1270ZF324|2210Z)/EPM2210

    mobiliya@mobiliya:~/opencl_examples/vectoradd/vector_add$ lspci | grep -i altera
    06:00.0 Processing accelerators: Altera Corporation Device 2494 (rev 01)

    mobiliya@mobiliya:~/opencl_examples/helloworld/hello_world$ bin/host
    Querying platform for info:
    ==========================
    CL_PLATFORM_NAME = Intel(R) FPGA SDK for OpenCL(TM)
    CL_PLATFORM_VENDOR = Intel(R) Corporation
    CL_PLATFORM_VERSION = OpenCL 1.0 Intel(R) FPGA SDK for OpenCL(TM), Version 17.1

    ERROR: CL_DEVICE_NOT_FOUND
    Location: ../common/src/AOCLUtils/opencl.cpp:356
    Query for number of devices failed[/QUOTE]
    Last edited by vinodk; March 14th, 2018 at 08:42 PM.

  2. #22
    Join Date
    Jan 2017
    Posts
    759
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Does "aocl diagnose" pass? If not, you should repeat the process of initializing the board until aocl diagnose passes.

  3. #23
    Join Date
    Mar 2018
    Posts
    1
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Hi vinodk,

    I work on the same topic like you and I have a compilation issue.
    When I try to compile the kernel hello_world.cl (aoc device\hello_world.cl -o bin\hello_world.aocx -board=a10gx) I get the next error:

    Error: The following files were not archived
    Error: ERROR: Archiver failed because there were no files to archive
    Error: Failed to generate 'base_bak.qar'
    Error (23031): Evaluation of Tcl script c:/intelfpga_pro/17.1/quartus/common/tcl/apps/qpm/qar.tcl unsuccessful
    Error: Quartus Prime Shell was unsuccessful. 7 errors, 0 warnings
    Error (23031): Evaluation of Tcl script import_compile.tcl unsuccessful
    Error: Quartus Prime Compiler Database Interface was unsuccessful. 1 error, 0 warnings
    Error: Compiler Error, not able to generate hardware

    I do not know what could be the problem. Searching on the Board documentation I fount this:

    Attention:
    The native Arria 10 GX FPGA Development Kit does not automatically work with the SDK. Before using the Arria 10 GX FPGA Development Kit with the SDK, you must first contact your field applications engineer or regional support center representative who will configure the development kit for you.

    Could you help me with this issue please?

    Thank you!

  4. #24
    Join Date
    Jan 2017
    Posts
    759
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    @paulbalan21, carefully read and follow this document:

    https://www.altera.com/en_US/pdfs/li...ng_started.pdf

  5. #25
    Join Date
    Feb 2018
    Posts
    16
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Quote Originally Posted by HRZ View Post
    Does "aocl diagnose" pass? If not, you should repeat the process of initializing the board until aocl diagnose passes.
    Hi HRZ,

    Now "aocl diagnose" does not work. So tried to repeat the setup process to make aocl diagnose to pass. However got stuck again while programming top.sof (of a10_ref_initialization.tgz package)file to board.

    mobiliya@mobiliya:~/temp$ sudo killall jtagd
    mobiliya@mobiliya:~/temp$ sudo jtagconfig
    1) USB-BlasterII [3-5]
    02E660DD 10AX115H1(.|E2|ES)/10AX115H2/..
    020A40DD 5M(1270ZF324|2210Z)/EPM2210

    mobiliya@mobiliya:~/temp$ quartus_pgm -c 1 -m JTAG -o "p;max5_150.pof@2"
    Info: ************************************************** *****************
    Info: Running Quartus Prime Programmer
    Info: Version 17.1.0 Build 240 10/25/2017 SJ Pro Edition
    Info: Copyright (C) 2017 Intel Corporation. All rights reserved.
    Info: Your use of Intel Corporation's design tools, logic functions
    Info: and other software and tools, and its AMPP partner logic
    Info: functions, and any output files from any of the foregoing
    Info: (including device programming or simulation files), and any
    Info: associated documentation or information are expressly subject
    Info: to the terms and conditions of the Intel Program License
    Info: Subscription Agreement, the Intel Quartus Prime License Agreement,
    Info: the Intel FPGA IP License Agreement, or other applicable license
    Info: agreement, including, without limitation, that your use is for
    Info: the sole purpose of programming logic devices manufactured by
    Info: Intel and sold by Intel or its authorized distributors. Please
    Info: refer to the applicable agreement for further details.
    Info: Processing started: Tue Mar 20 10:27:54 2018
    Info: Command: quartus_pgm -c 1 -m JTAG -o p;max5_150.pof@2
    Info (213045): Using programming cable "USB-BlasterII [3-5]"
    Info (213011): Using programming file max5_150.pof with checksum 0x00908D89 for device 5M2210ZF256@2
    Info (209060): Started Programmer operation at Tue Mar 20 10:27:55 2018
    Info (209017): Device 2 contains JTAG ID code 0x020A40DD
    Info (209018): Device 2 silicon ID is ALTERA10-6
    Info (209044): Erasing MAXII/MAXV configuration device(s)
    Info (209023): Programming device(s)
    Info (209021): Performing verification on device(s)
    Info (209011): Successfully performed operation(s)
    Info (209061): Ended Programmer operation at Tue Mar 20 10:28:00 2018
    Info: Quartus Prime Programmer was successful. 0 errors, 0 warnings
    Info: Peak virtual memory: 422 megabytes
    Info: Processing ended: Tue Mar 20 10:28:00 2018
    Info: Elapsed time: 00:00:06
    Info: Total CPU time (on all processors): 00:00:01
    mobiliya@mobiliya:~/temp$ quartus_pgm -c 1 -m JTAG -o “p;top.sof”
    Error (213008): Programming option string "“p" is illegal. Refer to --help for legal programming option formats.
    top.sof”: command not found
    mobiliya@mobiliya:~/temp$

    Tried to program top.sof using quartus programmer( GUI utility) however failed at next step to program boardtest.aocx. Command "aocl list-devices" does not lists the board.

    mobiliya@mobiliya:~/temp$ aocl flash acl0 boardtest.aocx

    aocl flash - Initialize the FPGA with a specific startup configuration.


    Usage: aocl flash <device_name> <file.aocx>

    Supply the .aocx file for the design you wish to set as the default
    configuration which is loaded on power up.

    Description:

    This command initializes the board with a default configuration
    that is loaded onto the FPGA on power up. Not all boards will
    support this, check with your board vendor documentation.


    aocl list-devices
    --------------------------------------------------------------------
    Warning:
    No devices attached for package:
    /home/mobiliya/intelFPGA_pro/17.1/hld/board/a10_ref
    --------------------------------------------------------------------
    Last edited by vinodk; March 19th, 2018 at 09:17 PM.

  6. #26
    Join Date
    Feb 2018
    Posts
    16
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Quote Originally Posted by paulbalan21 View Post
    Hi vinodk,

    I work on the same topic like you and I have a compilation issue.
    When I try to compile the kernel hello_world.cl (aoc device\hello_world.cl -o bin\hello_world.aocx -board=a10gx) I get the next error:

    Error: The following files were not archived
    Error: ERROR: Archiver failed because there were no files to archive
    Error: Failed to generate 'base_bak.qar'
    Error (23031): Evaluation of Tcl script c:/intelfpga_pro/17.1/quartus/common/tcl/apps/qpm/qar.tcl unsuccessful
    Error: Quartus Prime Shell was unsuccessful. 7 errors, 0 warnings
    Error (23031): Evaluation of Tcl script import_compile.tcl unsuccessful
    Error: Quartus Prime Compiler Database Interface was unsuccessful. 1 error, 0 warnings
    Error: Compiler Error, not able to generate hardware

    I do not know what could be the problem. Searching on the Board documentation I fount this:

    Attention:
    The native Arria 10 GX FPGA Development Kit does not automatically work with the SDK. Before using the Arria 10 GX FPGA Development Kit with the SDK, you must first contact your field applications engineer or regional support center representative who will configure the development kit for you.

    Could you help me with this issue please?

    Thank you!
    Hi,

    I think you need to follow HRZ's recommendation of openCL setup guide.

  7. #27
    Join Date
    Jan 2017
    Posts
    759
    Rep Power
    1

    Default Re: helloworld issue on arria10Gx development kit

    Quote Originally Posted by vinodk View Post
    mobiliya@mobiliya:~/temp$ quartus_pgm -c 1 -m JTAG -o “p;top.sof”
    Error (213008): Programming option string "“p" is illegal. Refer to --help for legal programming option formats.
    top.sof”: command not found
    mobiliya@mobiliya:~/temp$

    Tried to program top.sof using quartus programmer( GUI utility) however failed at next step to program boardtest.aocx. Command "aocl list-devices" does not lists the board.
    It seems you copy/pasted the command from somewhere (a PDF or Word file?) and an incorrect quotation mark (“ instead of ") was pasted in your command line. Try rerunning the command using the correct quotation mark.

Similar Threads

  1. opencl issue helloworld
    By vinodk in forum OpenCL
    Replies: 0
    Last Post: February 26th, 2018, 08:23 PM
  2. Replies: 0
    Last Post: February 26th, 2018, 08:18 PM
  3. Replies: 0
    Last Post: February 26th, 2018, 07:50 PM
  4. Replies: 1
    Last Post: February 13th, 2018, 05:31 PM
  5. Arria10GX aocl diagnose failed
    By matthewyih in forum OpenCL
    Replies: 1
    Last Post: August 26th, 2017, 11:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •