Results 1 to 3 of 3

Thread: DE1 SoC hangs when programmed

  1. #1
    Join Date
    Mar 2018
    Posts
    2
    Rep Power
    1

    Default DE1 SoC hangs when programmed

    Hi!

    I have made a small program to make a led flicker and programmed the FPGA with it. Everything went fine. However I have another project which I used to build in a previous version of quartus II and program it on an older cyclone II FPGA. I build this same project with the newer quartus II version 17.1 with no errors. However, when I try to program the cyclone V the following happens: the process starts properly, reaches 86% and then fails. After that I have to power off and on the FPGA so that it works again.

    Any idea would be appreciated. Thank you.

  2. #2
    Join Date
    May 2013
    Posts
    905
    Rep Power
    1

    Default Re: DE1 SoC hangs when programmed

    Is the project targeting the correct device on your board? Did you adjust the pin assignments in the Pin Planner?

  3. #3
    Join Date
    Mar 2018
    Posts
    2
    Rep Power
    1

    Default Re: DE1 SoC hangs when programmed

    Quote Originally Posted by sstrell View Post
    Is the project targeting the correct device on your board? Did you adjust the pin assignments in the Pin Planner?
    Yes, sure! Actually I am not that beginner. I have worked quite a lot with FPGAs.

    It used to give me a warning saying that the write logic was disabled. I rewrote my ram file and the warning dissapeared. I have also a warning stating the following:

    Warning (332060): Node: counter2 was determined to be a clock but was found without an associated clock assignment.
    Info (13166): Register \process_1:cnt[0] is being clocked by counter2

    Anyway, the project used to work on older software/hardware versions so I do not believe that the problem is related to code.

    I got it to work fixing the warning about the ram. However it only works under restricted parameter's values, so there is still something missing...

    Thanks.

Similar Threads

  1. MAX10 programmed with POF won't start
    By dejan in forum Quartus II and EDA Tools Discussion
    Replies: 8
    Last Post: March 2nd, 2018, 11:43 PM
  2. Buying pre-programmed MAX 10's
    By ereikes in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 1
    Last Post: February 5th, 2016, 02:39 AM
  3. Anti Fuse Programmed FPGA
    By BilalQureshiAltera in forum FPGA, Hardcopy, and CPLD Discussion
    Replies: 1
    Last Post: April 9th, 2014, 04:12 AM
  4. voltage of 3.3v not achieved even though programmed
    By rbanerjee2 in forum General Altera Discussion
    Replies: 4
    Last Post: April 3rd, 2012, 09:45 PM
  5. something wrong when I programmed my flash
    By cadixiao in forum General Altera Discussion
    Replies: 0
    Last Post: November 13th, 2010, 01:09 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •