Results 1 to 5 of 5

Thread: Arria 10 Dev Kit - DDR4 calibration failed

  1. #1
    Join Date
    Jun 2018
    Posts
    2
    Rep Power
    1

    Default Arria 10 Dev Kit - DDR4 calibration failed

    Hi everyone,

    I can't get the DDR4 module that comes with the Arria 10 Dev Kit to work. When I configure the DDR4 design using BTS, I get "DDR4 calibration failed, test won't work" error message. All other examples working fine (Flash/GPIO, FMC loopback and DDR3). Is there any configuration / setting that I am not ware of?

    Thanks

  2. #2
    Join Date
    May 2013
    Posts
    853
    Rep Power
    1

    Default Re: Arria 10 Dev Kit - DDR4 calibration failed

    If DDR3 works, DDR4 should work. Have you swapped out the memory in the Hi/Lo port?

  3. #3
    Join Date
    Jun 2018
    Posts
    2
    Rep Power
    1

    Default Re: Arria 10 Dev Kit - DDR4 calibration failed

    Quote Originally Posted by sstrell View Post
    If DDR3 works, DDR4 should work. Have you swapped out the memory in the Hi/Lo port?
    Yes, I did swap out the memory module.

  4. #4
    Join Date
    May 2013
    Posts
    853
    Rep Power
    1

    Default Re: Arria 10 Dev Kit - DDR4 calibration failed

    BTS should work out of the box. If it's not, I'd contact Intel for a replacement.

  5. #5
    Join Date
    Jun 2007
    Location
    Penang
    Posts
    176
    Rep Power
    1

    Default Re: Arria 10 Dev Kit - DDR4 calibration failed

    Check if the following setting is ON:

    set_global_assignment -name RELEASE_CLEARS_BEFORE_TRI_STATES ON

    If it is as shown above, then you need to change it to OFF and then try again

    set_global_assignment -name RELEASE_CLEARS_BEFORE_TRI_STATES OFF

Similar Threads

  1. Arria 10 DDR4 EMIF Burst Length Expansion
    By awells in forum IP Discussion
    Replies: 3
    Last Post: February 26th, 2018, 11:01 AM
  2. Clock issue with simple DDR4 implementation for Arria 10 SoC Dev Kit
    By eric.bader@tetravue.com in forum SoC Discussion
    Replies: 1
    Last Post: June 24th, 2017, 06:29 PM
  3. Nios II/f and DDR4 memory with Arria 10 dev board
    By arlinpierce in forum SoC Discussion
    Replies: 2
    Last Post: June 22nd, 2017, 10:11 AM
  4. DDR3 Uniphy calibration failed
    By gordwait in forum IP Discussion
    Replies: 1
    Last Post: October 2nd, 2013, 09:27 AM
  5. Replies: 0
    Last Post: May 21st, 2012, 05:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •